[Tuto] Installer RPG Maker XP et Pokémon Script Project

Pages: [1]

Sainior

  • Membre
  • 6362 posts
25 février 2011, 21:29
Ok, alors finalement, on va prendre la toute dernière version de PSP : PSP DS. Elle est encore en développement, mais sachez que je viens de la tester, et il est possible de faire un jeu avec, bien que certaines fonctionnalités ne soient pas encore présentes, comme le tactile.

Cela dit, ça arrivera dans les prochaines versions, je vous tiendrai au courant.

Donc, pour commencer ce tutoriel, quelques liens, où vous pourrez trouver TOUT ce dont vous avez besoin !



RPG Maker XP, version anglaise légale, évaluation 30 jours. Je vous déconseille de prendre ça, c'est légale mais c'est en anglais et c'est une version d'éval'. Passons à la suite.

INDISPENSABLE ! C'est le pack de ressources, il va vous servir à compléter le logiciel et à le faire fonctionner.

Pokémon Script Project DS, version bêta 0.3, indispensable. C'est là-dessus que vous travaillerez.

Ancienne version de PSP, lags et graphismes GBA, bref, ne téléchargez ça QUE pour la version française de RPGM-XP incluse dedans. Notez que cette version est illégale.



Passons à l'installation. Décompressez ce qui est à décompresser, et lancer le setup des ressources en premier, c'est très important ! Installez-les, et une fois fait, vous pouvez supprimer le setup, il sert plus à rien, vos ressources sont installées.

Installez PSP4G+ en double-cliquant sur le setup. Ensuite, ouvrez le fichier contenant Pokémon Script Project version 4G+ (l'ancienne), et exécutez PSP_mod. Si rien ne se passe, où si vous avez un message d'erreur, il vous faudra au préalable installer RPGM-XP version anglaise d'évaluation.

Enfin, passons à des manipulations un peu plus... complexe. Ouvrez le fichier PSPDS bêta 0.3 après avoir lancé et terminé avec le setup (petite icône orange). Dedans, les fichiers et dossiers suivants sont inclus :

Citer
-Audio
-Data
-Echange
-Graphics
-Polices

-Crédits
-Forum
-Game
-Game
-Language (.zip)
-Lisez-moi
-LoadingLog
-Log
-Manuel
-RGSS100J_seven_&_vista.dll
-RGSS100J_xp.dll

Si vous êtes sous Vista ou Seven, renommez le fichier RGSS100J_seven_&_vista.dll en RGSS100J.dll et supprimez le fichier RGSS100J_xp.dll. Sinon, faites la même manip', mais avec le fichier concernant XP.

Ensuite, faites un copier-coller du fichier modifié dans votre System32.

Décompressez le fichier Language. Ensuite, lancez l'application Game (avec un icône de Nintendo DS noir). Cliquez sur OK à chaque message, et quand il dit qu'il va faire une mise à jour, cliquez sur la croix rouge en haut à droite. MàJ terminée, message d'erreur.

Supprimez le fichier Language. Lancez l'application Game une seconde fois et... miracle ! Ça fonctionne ! Dans RPG Maker XP, pour travailler sur PSP, ouvrez un nouveau projet et sélectionnez l'autre fichier Game. Vous pouvez jouer à la version faite par l'auteur, il vous explique ce qu'il a fait dedans.



Voilà, je ne dirai pas comment fonctionne RPG Maker XP, des tas de tutoriels existent sur le net, une simple recherche Google, et c'est fini. Pour développer de bons jeux, je rappelle que savoir programmer en Ruby est un énorme atout, et vous permettra de faire des scripts très puissants dans le jeu.

Voilà, si vous avez des questions, je suis tout ouïe, j'y répondrai si le tutoriel ne le fait pas déjà ^-^

The ghost

  • Membre
  • 981 posts
25 février 2011, 21:45
Merci j'y suis arriver  ;)
Enfin ...
« Modifié: 26 février 2011, 10:56 par yoyoyo_X25 »

Ksilee

  • Membre
  • 1275 posts
15 mars 2011, 17:58
Est-ce que quelqu'un pourrai m'envoyer ce fichier par mail (à ksilee@hotmail.fr) car je ne sais pas pourquoi, mais mes téléchargements sur megaupload et autres sites de téléchargements (mediafire ect...) beuguent.
« Modifié: 16 mars 2011, 14:11 par Ksilee »

Edualc

  • Membre
  • 7373 posts
15 mars 2011, 18:21
Merci beaucoup Sainior, le jour où j'aurais le temps, je pense que je serais fou de joie de me relancer dans RPG Maker... avec PSP que je n'ai jamais testé en plus, j'en suis tout content d'avance! :)

Sainior

  • Membre
  • 6362 posts
15 mars 2011, 19:53
Pas de quoi :roumi:

-S@M-

  • Membre
  • 5394 posts
15 mars 2011, 22:12
Si quelqu'un s'en sert vraiment un jour, j'aimerais bien qu'il m'explique en détail le fonctionnement de RPGMXP et de PSP parce que d'habitude je suis autodidacte, mais là je dois avouer que c'est la merde à installer puis à comprendre et enfin à compiler donc je vais laisser tomber jusqu'à avoir des explications claires

Ksilee

  • Membre
  • 1275 posts
16 mars 2011, 14:12
Est-ce que quelqu'un pourrai m'envoyer ce fichier par mail (à ksilee@hotmail.fr) car je ne sais pas pourquoi, mais mes téléchargements sur megaupload et autres sites de téléchargements (mediafire ect...) beuguent.
C'est pas la peine j'ai réussi

Kérian

  • Membre
  • 27 posts
05 décembre 2011, 19:52
Pour moi, ça ne marche pas du tout mais alors pas du tout. Il y a des rapports d'erreurs toutes les 5 minutes qui qui plus est sont incompréhensibles. Par exemple, ca me met : la résolution doit être de 1400*768, un truc dans le genre. Ou bien, erreur Data exe. Inserez le fichier log-login.exe (je ne suis pas sur que ce soit exactement ce fichier).

Quelqu'un peut-il m'aider.

Je précise que j'ai un Eee PC et c'est peut être pour cela.

Edualc

  • Membre
  • 7373 posts
05 décembre 2011, 20:01
RPG Maker peut pas tourner sur un écran à faible résolution sans patch.

http://www.rpg-maker.fr/programmes-type-rpgmaker-rtp.html

Cherche RPG Maker XP 1.01, tu trouveras dans son pack un patch pour résoudre le problème de résolution. Si ton anti-virus s’affole, c'est un faux-positif.

Xephyr

  • Membre
  • 845 posts
05 décembre 2011, 20:21
PSP DS n'est pas obligatoire, il y a d'autres versions, tout dépend du résultat que l'on souhaite obtenir  :teci:

Flower//

  • Invité
05 décembre 2011, 20:37
Non mais ce n'est pas là le problème, juste sa résolution d'écran qui ne permet pas d'utiliser RPGM, il faut un patch je crois.

Ah mais Eduac avait déjà tout dit.  :cheval
« Modifié: 05 décembre 2011, 20:39 par Flow' »

ShootingStarD.

  • Membre
  • 43 posts
15 avril 2016, 18:48
Normal que le lien pour le pack de ressource ne fonctionne pas?

Nuri Yuri

  • Modérateur de section
  • 577 posts
16 avril 2016, 00:41
Mega Upload a fermé donc oui. Voici une page sur laquelle il y a un lien valide :
https://communityscriptproject.com/?action=sk&v=psp

Après tu peux trouver des variantes dans la section starter kit du forum :p

ShootingStarD.

  • Membre
  • 43 posts
16 avril 2016, 10:34
Ok merci :)
Et tu parles de la section de pokemon trash ou de PSp?

Nuri Yuri

  • Modérateur de section
  • 577 posts
16 avril 2016, 12:30
Y'a pas d'équivalent sur Trash donc de CSP x)

Pages: [1]    En haut ↑