[Advance Map] Créer des ponts.

Pages: [1]

Pichu388

  • Membre
  • 413 posts
10 juillet 2017, 18:12
  Bonjour, bonsoir. J'ai découvert, après quelques recherches, un moyen de faire des ponts (un bloc qu'on peut traverser par dessus et par dessous). J'ai donc décidé d'expliquer comment faire en partageant cette astuce.

  Tout d'abord, voici une petite explication technique. Dans l'onglet mouvement de Advance Map, on trouve le bien connu 1, le bloc qu'on ne peut pas traverser. Le 0 permet de passer à travers plusieurs couches. Ensuite, différents blocs par "étage" existent: une couche traversable (de 4 en 4 en héxadécimal (4,8,C,10,14 etc...), et son bloc solide correspondant (ce nombre plus un, mais le bloc 01 fait la même chose). La majorité des autres permissions de passage gèrent juste des étages supplémentaires, à l'exception de 3C qui permet de garder la couche actuelle. En gros, si on est sur la couche n°2, ce qui correspond à C, on ne pourra marcher que sur des C et des 3C. On peut faire ça avec n'importe quel étage, par exemple le 4, pour un pont au dessus de l'eau par exemple (où on pourra passer uniquement sur le 4 et le 3C).

  Notre second atout est la couche n°3 (ou supérieur). Cette couche correspond donc à 10. Comme on le sait, sur Advance Map, dans l'éditeur de blocs (Ctrl + B pour les étourdis), il y a deux couches de bloc. Une à gauche, la couche du dessous, que le joueur recouvre, et la couche du dessus, qui, excepté si on met "bloc caché par le joueur", recouvrira le joueur. Utile pour cacher un joueur sous un arbre, par exemple. Cependant, si un joueur est à la couche n°3 ou supérieure, cette règle n'est plus appliquée et le joueur recouvre les deux couches. C'est ce qui nous permettra de passer sur et sous le pont.

  Maintenant, si on veut créer un pont, il suffit de faire comme sur ces images :

Et voilà, votre pont est fonctionnel en jeu!

Source : http://zuren.darkbb.com/t11-advance-map-tutorial
« Modifié: 10 juillet 2017, 21:30 par Pichu388 »

hremeraude

  • Membre
  • 11394 posts
10 juillet 2017, 18:26
Quand tu utilises la balise [img] , dedans tu mets l'url de l'image, pas url=... , parce que pour le coup on ne voit pas l'image.

Pichu388

  • Membre
  • 413 posts
10 juillet 2017, 18:35
Oups :roll: et voilà

Guitoh

  • Membre
  • 5986 posts
10 juillet 2017, 20:10
Cool comme astuce, tu peux essayer d'améliorer un peu la prez juste, là ca fait un peu pavé ;)

Pages: [1]    En haut ↑